Bup bip bop… a calcular… a calcular… a iniciar a sequência 42…
Bom, parece que aqueles robôs malucos estão outra vez a armar das suas! Assumiram o controlo desta página e traduziram-na para o idioma local do utilizador. No entanto, os robôs têm boas intenções e um grande coração (de metal). Apenas pretendem ajudar! Indique-nos como os robôs se estão a portar utilizando os botões na parte inferior da página. Aceder à versão em inglês

O nome de ficheiro meu ficheiro de inicialização de PHP necessita de utilizar?

Ficheiros de inicialização de PHP podem gerir formulário, servidor e variáveis ambientais, bem como os cookies do lado do servidor, diretórios temporários, apresentação de erro e o registo de erros. Pode ver as diretrizes com que estes ficheiros, podem controlar em Documentação do PHP.

O nome do ficheiro que seu inicialização de PHP deve utilizar depende do tipo de conta que tem (de alojamentomais informações).

Tipo de O nome de ficheiro (Localizaçãomais informações)
Alojamento na internet - Linux com o PHP 5.6 (informações) php56.ini Raiz da conta (um por conta)
Alojamento na internet - Windows com PHP 5.4 (informações) .user.ini1 Raiz da conta (um por conta)
Todos os outros de Alojamento na internet php5.ini Raiz da conta (um por conta)
cPanel 4 .user.ini1 /public_html (um por conta)
Plesk .user.ini1 Raiz do sítio da Internet (um por sítio da Internet)
WordPress gerido .user.ini1,3 /html (um por sítio da Internet)

Se não vir o ficheiro que necessita listado na sua conta de alojamento, terá de criar um ficheiro com o nome de ficheiro indicado acima para o tipo de alojamento. Se as alterações no seu ficheiro de inicialização de PHP não são implementadas, temos disponíveis passos de resolução de problemas Aqui.

Contas de Alojamento na internet com o Windows com IIS 6 não é possível PHP e, portanto, não é possível efetuar os ficheiros de inicialização de PHP.

1 .user.ini ficheiros não permitem-lhe modificar todas as mesmas definições php.ini (ficheirosdocumentação do PHP) e apenas são compatíveis com versões PHP 5.4 e acima (Web & Classic / cPanel / Plesk).

2 também suporta o cPanel .user.ini ficheiros.

3 WordPress gerido contas também suportam a utilizar php.ini os ficheiros, mas devido a dificuldade em atualizá-los quando eles estão atualizados, recomendamos a utilização .user.ini em vez disso, os ficheiros.

4 Ao utilizar o cPanel, também pode modificar o ficheiro PHP. ini ao selecionar a versão de php clicando em que estiver a utilizar Mudar para opções de PHP. Para obter mais informações, consulte Visualizar ou alterar a sua versão do PHP no alojamento do cPanel.

Mais informações


Este Artigo Foi Útil?
Obrigado pelos seus comentários. Para falar com um representante do serviço de apoio ao cliente, utilize o número de telefone da assistência ou a opção de conversação acima.
Ficamos contentes por o termos ajudado! Podemos fazer mais alguma coisa por si?
Pedimos desculpas. Indique-nos o que era confuso ou o motivo pelo qual a solução não resolveu o seu problema.